Changesets missing after migration

Oct 10, 2008 at 1:48 PM
Edited Oct 10, 2008 at 1:50 PM
Hi,

We're in the progress of migrating a project (still doign dry runs for now, thankfully..). the tool seems to work nicely, except that it doesnt migrate all changesets!

what's the problem here?

Edit: during the migration, I often get: 
TfsToTfsMigrationToolUI.vshost.exe Error: 0 : The item $/MoveTest already exists.
    LogicalOperationStack=Migrate
    ThreadId=16
    DateTime=2008-10-10T12:52:57.4997405Z

other q, how to speed up the tool? on a small playground project, it takes 30minutes to run

Regards,

Matthijs ter Woord
Coordinator
Oct 11, 2008 at 5:23 AM
Hi Matthijs ter Woord,
Can you please post the Trace File form the migration.  It should be in the tool's install directory.  This will be a huge help in investigating your error.

As far as speeding it up, theres not a whole lot you can do short of moving it to a faster computer.  Please keep in mind that the tool will download every version of every file on the server then upload it again to the other server. That's alot of disk io and network traffic.

Thanks
Curtis
Oct 13, 2008 at 7:36 AM
Hi Curtis,

Thanks for your response. Sorry I didnt answer you earlier, but I didnt have access to my work pc.

I cannot disclose the logfile, as it contains source control pathnames, which contain sensitive filenames.

I did some further investigation, and it seems it's detecting conflicts. This seems weird to me, as i'm doing migrations to an empty project. Is there a way to have the tool always take the source file version, and overwrite the destination file?

Regards,

Matthijs ter Woord
Oct 13, 2008 at 11:14 AM
Status update: i did some changes to do automerging first, (my migration is from a project, to an empty project) and now everything seems to work fine (now in the process of catching all versions, and comparing them). Will let you guys know. Are you interested in getting back the changes?

Regards,

Matthijs ter Woord
Oct 13, 2008 at 1:01 PM
Status update 2: the migration did _NOT_ succeed, as i ended up with more files in the new project than in the original.
Oct 13, 2008 at 1:47 PM
after i did some more investigation, the migration succeeded successfully. appearantly, my tool to get all versions didnt work well.

Curtis, are you interested in my modified sources after i finish?
Coordinator
Oct 15, 2008 at 3:31 PM

Hey Matthijs,

I'm really glad to hear that you worked it out. Unfortunately, we are not allowed to take source code back from the community. Your welcome to start your own CodePlex project and post whatever changes you want there. 

If you were able to determine why you were getting conflicts, I would be very interested to hear that.

Thanks
Curtis

Oct 15, 2008 at 7:36 PM
hmm, funny version of opensource. it's basically a project like the rotor project was. that just sucks..

On Wed, Oct 15, 2008 at 5:31 PM, curtisp <notifications@codeplex.com> wrote:

From: curtisp

Hey Matthijs,

I'm really glad to hear that you worked it out. Unfortunately, we are not allowed to take source code back from the community. Your welcome to start your own CodePlex project and post whatever changes you want there.

If you were able to determine why you were getting conflicts, I would be very interested to hear that.

Thanks
Curtis

Read the full discussion online.

To add a post to this discussion, reply to this email (tfstotfsmigration@discussions.codeplex.com)

To start a new discussion for this project, email tfstotfsmigration@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com