Old versions of file in target directory

Jan 28, 2009 at 6:27 AM
Hi!
I have tried migrating a project  from a TFS 2005 server to a TFS 2008 server. This worked nicely in many respects. I get the files copied, and the source tree is built as expected. However, when checking individual files, I notice that they are old version. Months old. The version of these files appear to be completely random. It's not the first version, it's not the latest, and it's not a particular build or date. Just a random version. Some files arrive at destination with a complete history, and some with only half of it.

I do have the Team Systems VS 2008, Developer Edition, installed on my client machine, so this is probably not the issue. I get a lot of errors, as can be seen in This Screenshot. I haven't been able to find any more details about the errors I get.

I do realize that migrating from TFS 2005 to TFS 2008 is explicitly not recommended, but I was encouraged to post here with the details nonetheless.


As this appears to be the only tool available to solve this kind of issue, I really do appreciate the commitment and the quick respons I've recieved.

Does anyone know why this is not built into TFS? A simple function that sais "Import project from other TFS"? I should be a rather common task...

/flix
Coordinator
Jan 28, 2009 at 2:27 PM
Hi flixx,
There should be a Migration.log file in the directory which the tool was installed from.  The whole log is probably too long to post here, but the exceptions at the bottom would give us a clue as to why your migration is halting on this changeset.

thanks
Curtis
Jan 29, 2009 at 6:12 AM
I have searched, but cannot find any file with that name on my harddrive. I also looked in the applikation directory, but could find no log file of any kind there either.
Should I be looking somewhere else?

Thanks!
/Felix
Coordinator
Jan 30, 2009 at 3:25 PM
The full name of the file is "TfsToTfsMigrationTool-Trace.txt"  it might also be in the temp folder.

If its not being created it ussualy a sign of a permissions problem.  Make sure that you are running as an Administrator on the box.

Thanks
Curtis
Jan 30, 2009 at 6:04 PM
Hi!
Thanks again for the feedback.
However, I have administrator privileges on my workstation, as well as on the source TFS. I don't have it on the target TFS, although I do have enough permissions to do most things on it.

I had Windows search my entire C volume (my only volume!) for "Migration.log", and that might of course explain why I did not find "TfsToTfsMigrationTool-Trace.txt". I'll repeat the search with that filename first thing monday morning. I didn't search for just "*.log" since I'd get thousands of hits.
Feb 3, 2009 at 2:20 PM
Nope!
No file with that name on my harddrive...
Sorry!

I will have to try something else, I guess,. like following instructions and upgrading to to TFS 2008 before trying on the migration...

Thankyou very much for your time, though!